Zurück   Trojaner-Board > Web/PC > Alles rund um Mac OSX & Linux

Alles rund um Mac OSX & Linux: "Wake on Lan" geht nicht nach "shutdown -h now"

Windows 7 Für alle Fragen rund um Mac OSX, Linux und andere Unix-Derivate.

Antwort
Alt 24.04.2005, 19:55   #1
Wolferine
 
"Wake on Lan" geht nicht nach "shutdown -h now" - Standard

"Wake on Lan" geht nicht nach "shutdown -h now"



Hallo,

Ich hab hier auf einem etwas älteren Rechner Debian Sarge per netinstall installiert. Wake on Lan funtkioniert eigentlich auch wunderbar. Nur nicht mehr, wenn Ich den Debian Rechner per shutdown -h now runterfahre. Es geht dann nur wieder, wenn Ich den Rechner am rückwertigen Netzschalter ganz ab und wieder anschalte.

Hier nochmal ein paar Daten:
OS: Debian Sarge
Kernel: 2.6er (ka welcher genau)
NIC: LFE-8139ATX

Das ganze ist zwar jetzt kein sooo großes Problem aber es ist schon ziemlich lästig, wenn Ich den Rechner jedesmal erst vom Netz trennen muss, damit es wieder klappt.

mfg
Wolferine

Geändert von Wolferine (25.04.2005 um 05:24 Uhr)

Alt 25.04.2005, 05:23   #2
Wolferine
 
"Wake on Lan" geht nicht nach "shutdown -h now" - Standard

"Wake on Lan" geht nicht nach "shutdown -h now"



Mittlerweile konnte Ich das Problem wohl lösen.
Die Ausgabe von ethtool eth0 zeigte mir folgendes:

Zitat:
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 32
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: p
Current message level: 0x00000007 (7)
Link detected: yes
Wie Ich hier gelesen habe, steht das p für "Wake on phy activity" (was bedeutet das?).
Nach der Eingabe von ethtool -s eth0 wol g und einem anschließenden shutdown -h now funktinoierte das ganze dann auch wie gewollt und der Rechner ließ sich wieder aufwecken.
Leider aber nur einmal. Denn nun steht Wake-on auf d (disabled). In welche Datei müsste Ich ethtool -s eth0 wol g denn reinschreiben, damit das automatisch beim Booten aktiviert wird?
__________________


Alt 25.04.2005, 16:51   #3
piet
Gast
 
"Wake on Lan" geht nicht nach "shutdown -h now" - Standard

"Wake on Lan" geht nicht nach "shutdown -h now"



Ich zitiere mal aus dem Wiki-Artikel.

Zitat:
So aktiviert man das Wake-On-Lan beim Eintreffen eines "MagicPacket(TM)":

ethtool -s eth0 wol g
Ich habe diese Zeile einfach in meiner /etc/init.d/networking an entsprechender stelle gesetzt (nach dem aktivieren des Netzwerks).

Du musst den Eintrag also in das Networking-Startskript einfügen. Und zwar nach dem aktivieren der Netzwerkfunktionalität.


Alternative wäre

ethtool -s eth0 wol g

in die rc.local einzutragen.
Zitat:

Ein weiteres interessantes Systemkonfigurationsskript ist /etc/rc.d/rc.local,
das ausgeführt wird, nachdem die anderen Systeminitialisierungsskripten
gelaufen sind. (Wie kann das erreicht werden? Normalerweise wird ein
symbolischer Link auf rc.local in jedem der /etc/rc.d/rcN.d-Verzeichnisse mit dem Namen S99local
angelegt. Da 99 der höchstmögliche numerische Wert ist, den ein
S-Skript haben kann, wird es als letztes ausgeführt. Voilà!) Sie können
rc.local editieren, um jeden merkwürdigen oder ungewöhnlichen
Systembefehl zur Startzeit ausführen zu lassen. Auch wenn Sie sich
nicht sicher sind, wann ein solcher Befehl ausgeführt werden sollte,
ist rc.local die richtige Stelle. Auf Debian-Systemen gibt es
diese Datei nicht, aber niemand kann Sie daran hindern, selbst eine
solche anzulegen und sie von rc aus aufzurufen, wenn Sie das so gewohnt sind.
Quelle: http://www.oreilly.de/german/freeboo...ger/ch054.html

piet
__________________

Antwort

Themen zu "Wake on Lan" geht nicht nach "shutdown -h now"
daten, debian, down, geht nicht, großes, install, installier, jedesmal, lan, nicht mehr, problem, rechner, shutdown, trennen, wake on lan, ziemlich, ältere



Ähnliche Themen: "Wake on Lan" geht nicht nach "shutdown -h now"


  1. Nach Photo Transfer mit "MPE" nach"D", auf "C" ca. 5GB verloren? Rest: 5,6GB auf "C"!
    Alles rund um Windows - 17.04.2016 (21)
  2. Diverse Malware ("CoolSaleCoupon", "ddownlloaditkeep", "omiga-plus", "SaveSense", "SaleItCoupon"); lahmer PC & viel Werbung!
    Plagegeister aller Art und deren Bekämpfung - 11.01.2015 (16)
  3. "Fehler: Server nicht gefunden" immer noch nach "WAJAM.A.1"-Befall
    Plagegeister aller Art und deren Bekämpfung - 05.11.2014 (15)
  4. "Prozedureinsprungpunkt"_iob_func" wurde in der DLL "MSVCR70.dll" nicht gefunden
    Plagegeister aller Art und deren Bekämpfung - 11.03.2014 (4)
  5. "monstermarketplace.com" Infektion und ihre Folgen; "Anti-Virus-Blocker"," unsichtbare Toolbars" + "Browser-Hijacker" von selbst installiert
    Log-Analyse und Auswertung - 16.11.2013 (21)
  6. "Antiviren Werbung" "Langsamer PC" "PC stürzt ab" Banner und Popups beim surfen
    Plagegeister aller Art und deren Bekämpfung - 05.11.2013 (28)
  7. "Deutsche Post(eMail-Anhang)" Alle "EXE(Programme)" werden blockiert "WIN 7 Defender"
    Plagegeister aller Art und deren Bekämpfung - 27.12.2012 (3)
  8. "The document has moved. Redirecting"+"Popup unten rechts"+"Nicht alle Links anklickbar"
    Plagegeister aller Art und deren Bekämpfung - 24.10.2012 (38)
  9. Nicht sicher, ob PC nach "System Fix" Entfernung wieder "sauber"
    Log-Analyse und Auswertung - 07.01.2012 (18)
  10. Öffentliches Netzwerk: Opera sendet/empfängt Daten an/von "Dani-PC", "Anne-PC", "PAULA-HP"...
    Netzwerk und Hardware - 02.05.2011 (14)
  11. Netzwerk: Opera sendet/empfängt Daten an/von "Dani-PC", "Anne-PC", "PAULA-HP"...
    Alles rund um Windows - 16.04.2011 (0)
  12. Pc startet immer neu "shutdown -a" hilft nicht!
    Mülltonne - 24.10.2008 (0)
  13. "Adware.Virtumonde"/"Downloader.MisleadApp"/"TR/VB.agt.4"/"NewDotNet.A.1350"/"Fakerec
    Plagegeister aller Art und deren Bekämpfung - 22.08.2008 (6)
  14. "error cleaner" "privacy protector" "spyware und malware protection"
    Plagegeister aller Art und deren Bekämpfung - 28.06.2008 (2)
  15. Beheben des Problems "kein Internet"/"rsvp32_2.dll"/"Can't load library from memory"
    Plagegeister aller Art und deren Bekämpfung - 25.03.2007 (22)
  16. ">"">><meta http-equiv="Refresh" content="0;url=http://askimizsonsuza.com/code/">"">
    Plagegeister aller Art und deren Bekämpfung - 04.09.2006 (4)
  17. Im IE geht "Im neuen Fenster öffnen" und "suchen" nicht, Outlook spinnt...
    Alles rund um Windows - 24.02.2005 (2)

Zum Thema "Wake on Lan" geht nicht nach "shutdown -h now" - Hallo, Ich hab hier auf einem etwas älteren Rechner Debian Sarge per netinstall installiert. Wake on Lan funtkioniert eigentlich auch wunderbar. Nur nicht mehr, wenn Ich den Debian Rechner per - "Wake on Lan" geht nicht nach "shutdown -h now"...
Archiv
Du betrachtest: "Wake on Lan" geht nicht nach "shutdown -h now" auf Trojaner-Board

Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.